Unsupported Device or Computer

At Heritage we are committed to providing you with a high level of security.
We’ve detected that you are using an old device or operating system that is no longer secure for online banking.
For your safety and the safety of other Heritage customers, you will need to upgrade your device or operating system to a supported version.

The configurations below are supported by our systems.

Internet Browser
The latest versions of the following browsers:

Google Chrome, Microsoft Edge, Microsoft Internet Explorer 11, Mozilla Firefox

Computer Operating System

Microsoft Windows 7, Microsoft Windows 8, Microsoft Windows 8.1, Microsoft Windows 10

Apple OS X 10.9 (Mavericks), Apple OS X 10.10 (Yosemite), Apple OS X 10.11 (El Capitan), Apple macOS 10.12 (Sierra)

Mobile Browser
The latest versions of the following browsers:

Google Chrome, Apple Safari

Mobile Operating System

Android 4.4 (KitKat) or above

iOS 8 or above